- Kuzco 15s My character: https://youtu.be/MSTDahrE28Y
- Mory 17s http://www.novelupdates.com
- NovaQuinn 14s
- Fire 2m https://i.imgur.com/CF2ywFy.jpg
- geoux 4m
- Scarlyt 0s <3 <3 <3 The admins are the bestest! <3 <3 <3
- BSDGuy 22m
- Solshine 26s
- BCingyou 40s
- Dawnshot 34m https://youtu.be/qg_7saEbnwE
- Jeannisti 30s
- Dashiva 5m
- Vivvykins 6m
- Selly 36m
- Manywaters 24s youtu.be/AAbokV76tkU
- Brozilla 1h
- waddlerafter 22m
- Barrien 35m
- Oberst 1s
- TwistedAkai 18m examine, @newbie, @rules
- FairyBlue 12m
- Dumpster 9m
- Ryker 9m
c Mephisto 8m Malt doch nicht immer den Teufel an die Wand.
- FancyPenguin 45m
- Sara 4s
- Jade1202 3h
- Baron17 7s
- KalaniPup 32m
a Cerberus 1h Head Builder & GM when I need to
j Johnny 1d New Code Written Nightly. Not a GM.
- jsmith225 3m
- SacredWest 15m
And 29 more hiding and/or disguised
Connect to Sindome @ moo.sindome.org:5555 or just Play Now

White screen
It was fine before the restart

My compute goes to the screen to type in your password, name, and connect but I all I get is a white screen and can't send in any inputs to the server.

Clear your cache, give it a hard refresh when you're staring at that white screen.

I tried that and it didn't work. Is there any other way of fixing this?

Everyone else (including me) got that problem due to a file not being present when I restarted the webclient. Those of us who connected immediately after got this problem and we had to clear our cache to fix it.

Maybe try completely closing and restarting your browser if you can't otherwise lose the bad reference?