- Atheran 27s
- Jameson 28m making the eternal black firmament my side bitch
- Dawnshot 22m https://youtu.be/qg_7saEbnwE
- villa 29s
- ZaCyril 17s https://youtu.be/9r4WD60uM18
- DiamondNine 1m
- ThatOneGuy 29m Welp.
- Manywaters 27s youtu.be/HUxB4d_8ETM
- FancyPenguin 49s
- Grey0 4m
- Baron17 2m
- Chrissl1983 31m Really enjoying this awesome game to the fullest!
- Lycanthorph 17m
- crashdown 8m
- Ghostinthekeys 58s
- Diani 1h Shake hands with him! Charm her!
- Fire 1m https://i.imgur.com/CF2ywFy.jpg
- Melpothalia 45m
- Malanth 7h
a Cerberus 3h Head Builder & GM when I need to
- Cyberpunker 5h
- Scarlyt 10h Sindome is ace.
- Stelpher 1h
- stylo 5h
- jsmith225 8h
- YourLeftHand 7h
j Johnny 8h New Code Written Nightly. Not a GM.
- Azelle 5h
And 15 more hiding and/or disguised
Connect to Sindome @ moo.sindome.org:5555 or just Play Now

White screen
It was fine before the restart

My compute goes to the screen to type in your password, name, and connect but I all I get is a white screen and can't send in any inputs to the server.

Clear your cache, give it a hard refresh when you're staring at that white screen.

I tried that and it didn't work. Is there any other way of fixing this?

Everyone else (including me) got that problem due to a file not being present when I restarted the webclient. Those of us who connected immediately after got this problem and we had to clear our cache to fix it.

Maybe try completely closing and restarting your browser if you can't otherwise lose the bad reference?