- Sam_Guest 50s [Welcome to Sindome]
- SpecialK 2m https://youtu.be/6ZfuNTqbHE8
- DiamondNine 6m
- LizziePup 17m
- Selly 4s
- NovaQuinn 2m
- Baron17 1m
- Marioanius 30s Hamilton wrote, the other 51!
- wiebman 37m
- Tequilajoe 15m
- SolBro 3m
- villa 29s
- Jain 12s
- Fire 3m https://i.imgur.com/CF2ywFy.jpg
- Storm 18m
- jwimpeney 7m
- Rangerkrauser 9s
- Malanth 15m
- JMo 10m You're a single shake man! No time for the follow-up jiggle!
- Melpothalia 32m
- crashdown 25m
- Manywaters 2h youtu.be/HUxB4d_8ETM
- Speccy 2s
- whatislove00 2h https://www.youtube.com/watch?time_continue=795&v=fpbOEoRrHyU
- Satanic 5h
- Dawnshot 28m https://youtu.be/qg_7saEbnwE
- BCingyou 7s
j Johnny 2h New Code Written Nightly. Not a GM.
- jsmith225 3h
- Snowscoran 5h
a Cerberus 35m Head Builder & GM when I need to
- Chrissl1983 11h Really enjoying this awesome game to the fullest!
And 26 more hiding and/or disguised
Connect to Sindome @ moo.sindome.org:5555 or just Play Now

Bike Speeds [Bug Fix]
Bikes go the right speed now

So, an issue came to my attention. At some point bike top speeds had gotten wonky. We fixed the issue, which was that when a new engine was installed the top speed wasn't passed along. This was resulting in basically no change when a better or worse engine was added/removed.

We have fixed the code and I wrote a quick patch that updated all the bike top speeds that were incorrect. For some of you this means your bike has gotten a bit slower. Sorry, that sucks. Buy a better engine (or tires!) ;)

For more of you, this means your bikes have gotten a bit faster. Cool, try not to die!

If you encounter any issues, please let us know.

This makes a lot more sense. Thanks for the fix!