Reset Password
Existing players used to logging in with their character name and moo password must signup for a website account.
- Slyter 13m
- Tpritchett 2m
- SoftAndWet 1m
- Bombadil 4m
- Diamond 7h Back again
And 13 more hiding and/or disguised
Connect to Sindome @ or just Play Now

Action Unification System
Please excuse our dust.

As per the announcement, the switch to the Action Unification System has begun.

So far the bugs have been along the nature of not being able to walk, not being able to release grappled people, not being able to see things, not being able to stand up or sit down, people sitting AND standing, and various other problems.

The good news is these bugs are fixed, and hopefully won't be showing up again.

The bad news is this is a taste of what's to come in the next several weeks.

Now, some of you are undoubettedly going to wonder (because your the bright outside the box thinkers you are) 'Why, Kevlar, must you fuck with these things which have worked JUST FINE until you put your medling hands all over them?'.

The answer is several fold. On one hand the code does work, but it's very tightly coupled in certian places. By decoupling actions into a unified system that understands the problem, we accomplish two things:

1) We reduce the size and complexity of the codebase, and make things easier for the programer to fix things when they go wrong.

2) We provide for a way to introduce new actions into the game without having to make MOO wide changes, which is the main barrier to entry.

What does this mean? You know how you can sit, but you can't lie down? Well the reason is it's just too much of a pain in the ass to code it. With the action system in place, we can do it -very- easily. And that's just one example.

If you want to vent your frustrations, and talk about the changes that have negatively effected you as these changes come about, please do so here. Ideally you won't really notice things having changed, but occasionally there will be problems.

Game on!


Allright guys. After a while to let the critters manifest themselves, I've got back to work and knocked another 3 actions off the list.

The score is: 6 down, 10 to go.

These were some of the trickier ones. Although I'm avoiding the hardest one of them all: Combat.

Everything besides combat should be much easier. I just did the ones that are most likely to cause trouble in your every day life.

So keep thoes @bugs flowin, and whenever you get a TB (blue screen) make sure you @autobug right away!



Score: 8 down, 8 to go.
Excellent work so far!

*pulls out the pom poms and cheers you on*

Keep it up! Go go go, you vicious coding machine!

I eliminated an unnecessary one. 15 total.

Score: 13 down, with a bit of work still to do to remove old and (very) redundant code.

2 remain.

And that's that.

They're in every action now. And the benifits are allready starting to show themselves. We now have a very fine grained control over what you can and can't do while doing other things. There's other outstanding things that will be addressed at a later date, but the important ones are finished.

Thank you again for your paitence, and please continue to be on the lookout for bugs!


(Edited by Kevlar at 10:56 pm on Mar. 5, 2003) question.  @autobug?  I thought it was just @bug?  Has this changed?  Or do they both work? Okay....Maybe that was a couple questions....either way...
You @bug when you discover something wrong or something that dosn't work as advertised.

You @autobug when you get a traceback (blue screen).


Oh okay cool.  Thanks for clarifying.  I always just used @bug.....
If you notice odd behavior that happens when:

grappling / walking anywhere (following, sneaking, etc) / combat / unconscious players / being cuffed / aiming at someone / guarding an exit/ driving or being OOC

... that doesn't cause tracebacks, please submit a post here about the problem (feel free to change names to protect the IC) so we can track the issue.

If something causes a traceback, @autobug it to report the problem to us. Please do NOT post tracebacks to the bitch board under ANY circumstances.

These issues have been caused by the migration to the action system. An example of `odd behavior' would be repeatedly losing someone while following them. We've had reports that this is happening and its due to the action system change.

Depending on the response to this, we may change how you submit these reports at a future date.

~ J

oo oo. i get to go first! (not sure how you guys want this to be done but here goes)

location: sewer
action: combat

[note: yes yes i DO talk to the rats... *cough* stop laughing]

You [to Sewer Rat]: that's better
You cringe slightly as you take a wet grip on the slime covered rungs before hauling yourself up the access tube.
Sewer Rat moves to intercept you, blocking your exit.
Sewer Rat readies his claws and advances on you.
An adrenalin surge hits your system as you drop and turn to receive Sewer Rat's attack.
A twisted and battered shopping cart floats slowly past.
You sigh and growl at the rat.
Taking a firm grip on the metal rungs you haul yourself up into the welcome air of the street.
*end snip*

and then i was away. no fleeing. no combat. no beating up a rat with a flashlight... no nothing.

so uhm.. that was my odd behavior noticed.

the end.

Fixed. But be warned: When I fixed it, I fixed it pretty air tight. So watch out...

And thank you Bias for the bug report.


Oh...I don't really know why this happened, but while I was following someone out of Carnal D. I got a message that went something like:
"You can't start walking while you're walking."
...and I hadn't typed anything to elicit this. Perhaps conicidentally, my character also lost the person they were following at this point.
You gotta help me out with reproducing this one. Did you move at the same time or close to when he did on your own? Did he go, you follow but not stand, then stand, go, then he went? Because that would cause that.

Let me know if that's the case or if it's not you can reproduce it.


I had the same problem Lena did, but mine was when following someone to the roof of New Rose, go in -and- out the window, told me can't start walking while I'm walking or whatever.
Well, now I guess it's my turn.  I went to give Stev an item and this is what happened....

--You step out of the shadows into plain view.
You get out your Battox powercell.
You can't give Battox powercell to Stev.
Stev goes east.--

Might I note at this point that every time I give something to Stev it says that I can't...but I actually do...that might be another bug.  But to continue...

--You make your way to the east.
Stev [to You]: This is a real good one.
Stev [to You]: Talk to me later, I'd be glad to give you more work.
You appear to be broke...don't that just suck?
You [to Stev]: You gonna pay me for that?--

*shrugs as he continues with his RP*

Ok, I believe I've fixed the long standing and much complained about Grapple bug.

Grappling should no longer cause you to get in an invalid state when the person breaks free of you.

If for any reason, you find yourself victim to this bug, please STOP WHAT YOUR DOING, (use OOC to tell the other person to stop) and xhelp for me. If I'm not avalible, @bug it.